Safesky Skyecho2 issue


I recently purchased a premium subscription for SkySafe to use with my SkyDemon and SkyEcho2 gadgets. Currently, I’m receiving traffic data from SkySafe in my SkyDemon map, and it’s working well. However, I’ve noticed that as soon as I start flying in SkyDemon, the SkySafe app displays a window saying ‘Waiting for SkyEcho.’ I’m wondering if this is a bug, as it seems that once SkyEcho connects with SkyDemon, the connection to SkySafe is lost. I’d like to inquire if this is a known issue or if there are any downsides to this setup?



If you are getting message 'Waiting for SkyEcho", this means that the phone or tablet has no Wifi connection to the Stratux device.

The Stratux team has specific instructions on how to configure Android on their git page

More info on network connectivity and Android is also available from Safesky user manual

I am personally flying similar setup that is described here., and it’s a great combination.

Keep us posted, and fly safe,


Hello! Thank you for responding.

As I mentioned earlier, I’m using the SkyEcho2 device, which unfortunately doesn’t support WiFi Direct as recommended for Stratux devices to enable simultaneous WiFi and cellular connections. Additionally, the suggestion to change the WiFi settings from DHCP to Static and removing the IP address didn’t resolve the issue.

Therefore, I’ve resorted to using the Speedify app, which enables me to maintain a WiFi connection with SkyEcho and a cellular connection simultaneously, effectively providing internet connectivity.

I’m still unsure and curious about what is causing the issue with SafeSky.

Thanks for the feedbacks.

On IOS, it’s working just out of the box. On Android, we’ve had some hard times to test the different combinations of hardware, OS version, manufacturer software overlays… there is always somehow a solution, but it requires tweaking things.

As you know, it’s not SafeSky related, but network related with Android settings. Glad you managed to find a way though.

Fly Safe,