SafeSky Skyecho2 on SkyDemon

Hi all, I was using SafeSky + SkyEcho 2 on SkyDemon without any significant issues, but cca 5 days back (to me, it seems like it appeared after SafeSky update) it started to not functioning. More specifically it works ONLY IF I use split screen on iPad, where on one side is Safesky setup with SkyEcho2 (checked on the “blue dot” in the left upper corner") and other side of the screen is SkyDemon. With this setup, it works well. Once split screen is canceled and only Skydemon is shown, then signal from SafeSky i.e. SKyEcho 2 is lost. Any help, please? Many thanks, Jan

Hi Honza,
I have exactly the same problem with mine. I’ve been trying for a few weeks to get a resolution with no luck so far. I’ve checked all settings etc. It used to work fine up to recently.
I’ve just emailed Christophe again to see if he has anything new to try.

Thanks for sharing. If you get any update, please, post it to this thread as well. Thanks :slight_smile:

I had a reply from Christophe.
On my setup page, in ‘Traffic Sharing’, ‘Enable Traffic Sharing’ wasn’t selected on.
It’s not enough to only select SkyDemon.
I think this has solved my problem.

Hello, thank you, but it is not working for me. After a few seconds, I will get a message “Device Offline for XY seconds”. if I am not using a split screen. Would you mind please to share an email which I can reflect to?

Thanks a lot.

Send screenshots of your settings pages.

Thanks…Discussing this with @Tristan
We come back to you asap, after testing some config.

Best regards,

Hello guys, any update on that topic please? Meanwhile, I have to use Skydemon and Safesky without Skyecho2 in order to get at least some data as traffic. As a note, same result applies, if I use only Skydemon and Skyecho2 without Safesky, it also works. The issue is really only those three together. Thanks a lot, Honza

Dear @Honza
Tristan is working on it. We don’t have any problems with the SE2.

We prepare actively Aero 2024 and we are busy as a bee…
Anyway, could you be more explicit about your configuration?
iPad for SkYDemon, iPhone for SAfeSky? SIM card own the ipAd.
Thanks to share with us your exact configuration in order to be able to find where is your problem.

Thanks for your help…

Hello Christophe, I am using iPad Mini with SIM only, connected via Wifi to Skyecho 2, Safesky is running on the same device as Skydemon. Everything was working fine, till last week. As said in the first message, currently, if I am not running Safesky and Skydemon in split view on iPad, Skydemon would lose signal to Skyecho 2 and no traffic is visible whatsover. If I use Skydemon ONLY either with Skyecho2, OR Safesky, everything is ok.

Please, let me know if you need more details to this topic. Currently, I am flying without Skyecho2, but since this device was quite expensive, I am ofc a bit sad :smiley:
Many many thanks,

Strange. Same config for me, and I don’t have any problems…
Let me check with @Tristan but apologize for the delay, with AERO it will be very complicated for us to find time and search the issue

Thanks a lot for your help, we appreciate.

Hi again, Christophe, I even tried to do the same setup on a different device (iPhone) with totally same result. I have recorded the whole session from start to losing the device. Please, check on the link below so you are perfectly aware of what is going on :slight_smile:

Thanks a lot,

I have had a similar problem only a few days ago on a long flight. SkyDemon, sky echo and SafeSky. I flew past several planes and gliders and not alerts whatsoever.

I don’t remember this being a problem in the past.

At the AERO messe in Friedrichshafen this week I spoke to all 3 companies. SkyEcho (uAvionix), say that their device is quite dumb and merely receives data and sends this protocol to whatever other device is connected to it. As such in don’t think the problem is SkyEcho.

I will try SafeSky and SkyEcho each separately with SkyDemon to better see if I can isolate the problem. Any feedback in the meantime would be greatly appreciated!

Hi Urzwoo, to spare you some time in flight with testing, I have already done it, several times. Tried it in flight and ground too. Once I connect SafeSky and SkyDemon, there is no issue whatsoever. The same applies for the situation, if only SkyEcho2 is connected to SkyDemon. The only issue is everyhting together :frowning: What is super strange to me, that everything worked OK till few weeks back. I was using it from Aug 2023.

1 Like

Hi, to be fair, the team from SafeSky were really helpful at the AERO Messe and are aware of the problem. They suggested I also post on the forum here so that the topic gets more traction.

Let’s hope they can find and address the problem soon!


We have managed to reproduce the issue, and we are working on a fix to release shortly.

Thanks a lot for your help on this,



:star_struck: :kissing_heart: Thanks!!