Safesky on Skydemon (HELP)


I have a problem when I want to put SafeSky (premium) on Skydemon.
In Skydemon, I select: Fly → Use GDL90 Compatible D…
And nothing appears (not even my plane).

In Skydemon, If i select: Fly → Use Location Services
It work fine but I don’t see other trafic…

My phone is: Samsung A31

I have everything set up correctly as the site says.

Can you Help me please??


Thanks for your email.
This is a configuration in the SkyDemon menu.
When you select ‘Fly’, you need to select after ‘GDL90 devices’.
To be able to see GDL90 devices, you need to go to the menu of SkyDemon / Third-Party Devices / GDL90 compatible device and select it.

After this, when you will click on Goi Flying, you will see appear Use GDL90 Compatible Device. Select it !

Please let me know if this answer is helpful.

Best regards,

To see traffic, please click on take-off with SafeSky, and Go Flying with Skydemon.

Thank you for your fast responding!

My settings are already like yours (I wanted to show you but I couldn´t upload more than 1 screenshot).

I didn´t try to “take-off” with Safesky and “Fly” with Skydemon in the same time.

I’ll keep you informed if it´s work or not :slight_smile:

Thank you,


Indeed, you need to “Take off” from SafeSky to start transmitting traffic to Sky Demon.

Looking forward reading your response.

Fly Safe,


Hi xtof, hi Tristan,
currently I have also trouble to connect SafeSky with SkyDemon.
Settings are like recommended.
Interesting: In SkyDemon, the message “Waiting for Device” changes into “Waiting for GPS Fix” as soon as I press “TAKE OFF” in SafeSky.
So: defenetly, SkyDemon somehow sees the SafeSky device, but gets no GPS data (which works perfectly, if I just select “Localisation Services” in Sky Demon).


  • Both APPs are running on same iPad.
  • Same effect I see also on my Android phone. So this effect is plattform-independent.

I am adding snapshot from Android Phone.

Any suggestions, what’s going wrong is appreciated…
Thanks a lot.

Hello @Taildragger,
Do you use a external device such as SkyEcho or Flarm ?


If you’re in U.K. then call me and I’ll try and help. Mike 07885 397755

I am using no external device or GPS receiver. BR

Hi @Taildragger,

Please check that external device is OFF



yep. External Traffic Device is OFF.
Still no GPS Fix in SkyDemon.


Thank you very much!
I tested on the ground (at home) and it works!
I will try tomorrow in flight :slight_smile:

It’s me who misunderstood but maybe it would be better to explain on the site that you have to:

  1. Open Safesky first, click on “Fly”
    and then
  2. Open Skydemon in parallel and use GDL90

Have a good day

Hello @Taildragger, could you please try one more time so that I can make a diagnostic remotely? Just let me know when done,


Thanks for the feedbacks @adjduantloic . Happy to read this is working. We are going to improve this indeed,

SafeSky team

Hi Tristan,

just trying it now.
SafeSky (in take-off mode) and SkyDemon in “Go Flying” (with GDL90 device) now running in parallel on one device (iPad) for a while.

SkyDemon is still “Waiting for GPS Fix”.

Okay. Done. Stopping now both apps again.
Thanks for for your support and looking into this issue.


Tristan. I’ve helped Taildragger as much as I can and he has his settings correct. SkyDemon works fine on its own as does SafeSky. It’s when we put the two together. This is on iPad but he has exactly the same problem on android so must be a subscription problem surely?

Hello @Taildragger

Thanks a lot for your patience on this one. Could we arrange for a video call so that we can diagnostic together online? Just contact me by email at with a time preference ?

Fly Safe,


Can you please make the result public as I have the same problem with my iPad mini

Following help from @Taildragger , we have been able to diagnostic a bug.

The technical answer:
When SafeSky send GDL90 messages to SkyDemon, one of the message is called an ownership message, which contains your aircraft callsign in 8 bytes. In the configuration of @Taildragger , the callsign was entered with a non-ascii character: D–MPZI . The dash character can be short, medium or long. Only the short one is an ASCII character (1 byte), the others are unicode (2 bytes). Therefore, the GDL90 messages were corrupted.

The functional answer:
Make sure to enter a short dash character in your callsign, or no dash at all.

The resolution
A new release is on it’s way to the Stores with a permanent fix, even if you enter invalid characters.

Fly Safe Everyone,

SafeSky Team

Hello @AML ,

Thanks a lot for your message.

I checked your configuration, and I see you have both SkyDemon and SkyEcho (very good setup with SkyEcho by the way).

In this configuration, SkyEcho is responsible for sending GPS positon to SkyDemon. If you are just testing on the ground without connecting to the SkyEcho Wifi, then SkyDemon will say ‘Waiting for a fix’.

To remedy this, either add your phone or tablet to the SkyEcho Wifi (and make sure SkyEcho has a GPS fix); otherwise simply turn off “Enable external traffic device” for the duration of your tests on the ground. The second options allows you to test very easily from the confort of your sofa :slight_smile:

Please let me know if this is fixing your issue?

Fly Safe,


Hi Tristan

tried the second approach (from the sofa) & it didn’t resolve the issue as per the attached screenshots.