Safesky integration with Skydemon

Hello, I was using in flight so far with no issue my Samsung galaxy S7, with a tablet to integrate SkyDemon & SafeSky.


  • SafeSky hosted on the Smartphone S7, wifi hotspot activated on S7, SafeSky launched on S7
  • Tablet: SkyDemon, connected to S7 wifi hotspot, select GLD90 device
    ==> all working fine

I just changed my phone for a Samsung galaxy F62 (very high battery autonomy). Same configuration with SafeSky running on F62 + F62 in wifi hotspot ==> Skydemon doesn’t see any GLD90 device on the tablet though SafeSky is running fine on the F62, and tablet properly connected to Internet via the hotspot.

I have 2 tablets: if the two tablets are connected to the F62 wifi hotspot, and SafeSky running on tablet1 and SkyDemon on tablet2 ==> it works fine.

If F62 and one tablet are connected to home wifi ==> it woks fine.

Any idea why it is not working when F62 is in wifi hotspot mode, connected to Internet via 4G, and tablet is accessing to internet via the hotspot ?

I fail to undertsand what could be different between S7 and F62, or do I miss a setting in the F62 ?

Thanks for any help


Probably a setting with your new F62. We don’t change anything in SafeSky.
But Tristan is in copy of this in order to help you if we can.


Peut-être un pb d’autorisations sur le nouveau smartphone…?
Il faudrait comparer les Autorisations des applications sur le S7 et sur le F62, notamment pour SafeSky.




When GDL90 is configured from settings in auto-discovery mode, it’s expecting to find the android phone on a certain IP address ranges. Sometimes, the phone constructor is deciding to change hose defaults. It’s likely to be the case for the F62.

To remedy this, simply:

  • check the tablet IP address
  • Turn off auto-discovery mode from SafeSky GDL90 settings
  • Enter the tablet IP address from GDL90 settings

Please let me know if this is working?

Fly Safe,


Je regarde ça et reviens vers vous. Merci !

Ça fonctionne en effet en forçant l’adresse ip ! Merci beaucoup !
For English users, go to settings in SafeFly and untick up autodiscovery and enter the tablet ip address → it works !

Nb: ip a dress was

What is the ip range expected by SafeSky ? Will try to see if I can force the f62 to create ip range identical in tethering mode

Finally it is very weird. I tried again this afternoon and even forcing the IP adress @ was not working. I had to connect to the F62 wifi (one tablet @, the second one @, launch on one tablet SafeSky with autodiscovery and the other one with SkyDmon and it did work. But I am SURE it did work this morning, I just tried again with the smartphone running SafeSky, forcing IP adress @, green dot on the radar screen of SafeSky, launch SkyDemon on the tablet whose IP adress is but get the message “waiting for device”. I don’t understand why it did work this morning.
Bottom line: any chance that SafeSky autodiscovery IP mode extend the IP range to as nevetheless it did work this morning ? what is the current range accepted by the app ? thanks

Désolé pour l’avalanche de messages mais j’ai une question supplémentaire: Selon les développeurs de SafeSky, peut-on faire fonctionner SafeSky et SkyDemon en même temps sur la même tablette ? il semble que oui. Si c’est le cas, le problème est résolu, il suffit de se connecter au hotspot smartphone, lancer les deux applis. Mais pour je ne sais quelle raison j’étais persuadé que ça ne fonctionnait pas ainsi.

I flown several times using SafeSaky and SkYDemon
on the same tablet with GDL90 connection.
I use IPad mini 4 Wifi + SIM but the connection between the two systems is
unstable and even the GPS is often lost.
I don’t know if it’s because of the old iPad (?)…but I think this would be the perfect setup.
In the last two flights I used SafeSky with Iphone 12 and Skydemon with Ipad.
Ipad connected with hotspot to the iPhone.
I can confirm that everything is working fine.
If someone confirms that by changing iPad I can solve the problem, I will gladly change it.

The answer is yes.

Like tcx32, my tablet uses an IP address range that would not be a “standard” Android. So I have to manually set the IP address in Safesky. But every time I reboot the tablet, the IP address also changes. So I have to change it in SafeSky after each reboot.

Have nice flights