0.4 Zoom a BIG problem!

Hi all,

So, for sure, I keep my eyes-wide-open and in addition use SafeSky. Summer’s on and there are many gliders flying. Safesky keeps auto zooming to 0.4 NM. Any idea why?

If this is about situational awareness, I would have liked the pilot to set what needs them best. 0.4 NM certainly does not help, particularly when I am paying attention to the radio, and e.g. hear the glider joining the circuit to land.

Then SafeSky starts announcing … warning … but I cannot see anything since the zoom is at 0.4. This in my opinion is a hazard in itself. For sure, I kept my focus on flying and looking out, but the autozoom is a really bothersome.

This happens even during cruise. If you reset to 8 NM, which is my preference, after few minutes, still defaults to 0.4!!!

How can I avoid this please?

A development idea? An option for the pilot to set the zoom to either
a) manual,
b) autozoom
c) autozoom with min. and max. values that can be set by the pilot?

Any help available on this?

@Vincent

Hi @Ben,

The current behavior is that when there is traffic around you, SafeSky autozooms to provide an optimal view of that traffic. Once the traffic is no longer considered a potential danger, SafeSky reverts to the previous zoom level.

If there are multiple aircraft nearby, SafeSky will zoom in on the closest one, which may result in other traffic being “hidden.” Additionally, if there is continuous close-range traffic, the zoom level will remain close and won’t return to its original state.

Thank you for your suggestion, we really appreciate and we will be introducing this option shortly!

Many thanks @Vincent , appreciate it!

I’ll really look forward to this feature, for me, at 0.4 NM, I could not see any aircraft and that was a bit disconcerting! :slight_smile:

Have a good week!

Regards,
Ben

I totally understand, others have also reported this was annoying in certain circonstances.

You’ll find the setting under Security & Alerts in an upcoming release ! :wink:

Have a good week too !

1 Like

dear @Ben ,

Please check also if the zoom at 0,4NM is not provided by your own aircraft?
If you have a double echo of your aircraft, the zoom could be blocked at the more precise zoom, 0,4NM.
The double echo exists if you forget to mention you ICAO hex code of your transponder.
This is clearly explained in our manual:

Dear @xtof (Christophe), many thanks for the reply from Vincent and you! Yes, I do have the ICAO hex in the app, and I can see it! :slight_smile: I am looking forward to the new release!