Skydemon interface


I have been using SafeSky for a while, and while initially I could display targets on Skydemon, it’s not working anymore.

I have enabled traffic sharing on SS, selected SD as recipient (also tried as generic GDL90 device) and tried selecting “force to use SS as GPS device” on and off.

Targets do appear on SS itself.

On SD I start navigation using GDL90 device.
My own position is shown (both when SS is used as GPS device and when not), but no targets are shown.

Any ideas?

Thank you in advance.

First the obvious: You pressed “Takeoff” and saw the traffic in radar view in SS - right?

If so, maybe you have set a vertical filter in SD?


There’s no reason why it shouldn’t still work. Nothing has changed on our side.

Please check the following points:

  • Filters should be set to maximum to ensure that there is traffic in your transmission area.

  • Visit our website, which includes a video explaining exactly what needs to be ON/OFF, as well as the filters. Here is the link

Take a look at our new online manual: SafeSky - User Guide | SafeSky Library

Keep us posted

1 Like

Also check if external traffic devices is set to off.

Thank you all for your replies.

I watched the video and the settings were already as described there.

SD’s vertical filter is expanded to ensure it wouldn’t cut targets off.

External traffic devices is off.

Anything else I might be missing?

Thank you.


Can you post all the settings you made to configure the communication between SS and SD? Then maybe we can notice something (missing) …


Here are the screenshots.

Thank you.

Hmmm… I can’t see anything offending.

Perhaps something broke under the hood. It might sound like Voodoo, but if everything else fails, I would try an uninstall/reinstall of SD and SS.

Seems like dark magic worked. After reinstalling SS it’s all ok now.

Thanks everyone.

Top… Thanks to the forum users :wink:

1 Like