SafeSky (avec Skydemon et Stratux) plante après une minute sur Ipad mais pas sur Android

Bonjour,

Skydemon connecté en WIFI à mon Stratux fonctionne parfaitement bien sur Ipad (mini 6 WIFI + cellular). Skydemon fonctionne également parfaitement bien avec Safesky tournant sur le même Ipad en cellulaire (affichage des trafics “ss”). Malheureusement, la combinaison des deux (Skydemon en GDL90 avec SafeSky en cellulaire sur le même Ipad + Stratux en WIFI) pose problème. Initialement tout va bien : Skydemon affiche les trafics “ea” du Stratux et les trafics “ss” de SafeSky, mais au bout d’environ une minute, SafeSky “plante” (voyant rouge alors qu’il est toujours connecté en cellulaire) et Skydemon ne reçoit plus que les trafics “ea” du Stratux (car Skydemon se connecte alors en GDL90 au Stratux). cf. la video : Ipad - YouTube
J’ai fait le test avec mon téléphone Android et tout fonctionne parfaitement :

Merci de votre aide

1 Like

Bonjour,

Avez-vous effectué les essais en vol ou au sol?

Merci

Bonjour,

Merci pour votre retour. Il s’agit là d’essais au sol. Il m’a semblé que ce problème ne s’était pas présenté lorsque j’ai volé avec le Stratux et SafeSky en novembre (mais bon, en vol je regarde plutôt dehors…). Je me demande si ça ne viendrait pas de la dernière mise à jour sur Ipad?

Merci de votre aide

J’ai exactement la meme setup (mais iPas Air2). Je testerai aujourd’hui,…mais effectivement, pendant une vol la semaine passée, SS a se planté en vol sans enregistrer le log…

Merci pour ce retour.

J’ai moi même ce setup et c’est une belle combinaison en vol.

D’après votre vidéo, il semblerait qu’IOS ne route pas le trafic SafeSky vers la 4G, mais vers le Wifi du Stratux, d’où l’absence de trafic SafeSky au bout d’une minute.

Nous allons faire un diagnostic de notre côté, et revenir vers vous.

Fly Safe,

Tristan

Bonjour,

Merci pour votre réponse. J’ai effectué le test en vol ce matin : même problème. Par contre, après avoir décoché “activer un périphérique externe” dans les options de partage du trafic de SafeSky, l’Ipad reçoit le trafic du Stratux et celui de SafeSky, mais en alternance environ 2 fois par secondes (affichage du trafic avec un préfixe alternant entre “ea” et “ss”).

Bons vols

Bonjour !

J’ai l’intention d’utiliser mon Stratux avec SafeSky et je rencontre des problèmes pour que la combinaison fonctionne.

Ce que j’utilise :
iPad Mini 5 (WIFI et 4g)
Stratux (IP : 192.168.1.1 ; EU-28 flashé ; AHRS, baro et GPS)
Skydemon (version 3.16.4.350)
SafeSky (Premium)

Chaque fois que j’active sous “traffic sharing” le Stratux en tant que dispositif externe, SafeSky arrête de lire sur Internet après environ 50 secondes. Les avions identifiés par le Stratux sont toujours transmis à Skydemon. Cela signifie que le système continue de fonctionner mais sans l’nformation de SafeSky.
Après une période plus longue, il arrive que SafeSky s’arrête complètement. Mais cela n’arrive pas régulièrement. Skydemon est connecté à SafeSky comme “GDL90”.

Indication sur le bouton vert (en haut à gauche) :
(vert) Internet “4g”
(vert) SafeSky “Just now” → change après environ 50 sec. en un compteur sans fin
(vert) My Position “Just now” → change après environ 50 sec. en un compteur sans fin
(vert) Skydemon “Just now” (avec quelques interruptions pendant quelques secondes)
(vert) Stratux “Just now”

Lorsque je viens d’activer le WIFI sur l’iPad (sans Stratux connecté). La lecture est à peu près la même. Dans ce cas, aucune position n’est fournie à Skydemon car SafeSky recherche évidemment le signal GPS de Stratux :

La lecture sur le bouton vert est à peu près la même :
(vert) Internet “4g”
(vert) SafeSky “Just now” → change après environ 50 sec. en un compteur sans fin
(vert) My Position “Just now” → change après environ 50 sec. en un compteur sans fin
(vert) Skydemon “Just now” (avec quelques interruptions pendant quelques secondes)
(rouge) Stratux

Après le redémarrage de SafeSky, la connexion 4g est de retour (“Just now”), mais à nouveau seulement pour quelques secondes.

J’ai remarqué que seulement si vous appuyez sur “TAKE OFF” dans SafeSky le dispositif GDL90 est en ligne (lisible) pour Skydemon. Il me semble, que dès que le WIFI est activé et connecté, SafeSky a l’intention de se connecter à l’Internet via WIFI au lieu de rester connecté à 4g.

SafeSky seul (WIFI désactivé) fonctionne bien avec Skydemon.
En utilisant Startux (WIFI on) avec Skydemon directement connecté “FLARM with AIR CONNECT” Skydemon est capable de lire la météo etc. sur Internet en même temps.
Seule la combinaison des deux ne marche pas.

S’il vous plaît noter, tout a été essayé seulement sur le sol (sans déplacement) pour le moment.

En outre:
Je tiens à mentionner que j’ai récemment mis à jour vers iOS 15.7.2 et que cela semblait fonctionner normalement auparavant.
La solution se trouve peut-être quelque part ici : Use WIFI and Mobile data simultane… | Apple Developer Forums

Encore un :
Lorsque vous exécutez SS avec un périphérique externe activé (skydemon désactivé, stratux désactivé)

  1. iPad-WIFI désactivé : SS lit correctement (évidemment à partir de 4g)
  2. iPad-WIFI activé (connecté à l’internet domestique) : SS lit correctement (depuis le WIFI)
  3. iPad WIFI on (non connecté à quoi que ce soit) : Le SS arrête de lire après moins d’une minute
    Je pense que cela prouve que SS (avec un appareil externe activé) et après avoir appuyé sur “TAKE OFF” passe immédiatement à la lecture du trafic du WIFI, indépendamment de la présence ou non d’un internet-WIFI. Bien noté, la perte de la connexion internet ne se produit qu’après avoir appuyé sur “TAKE OFF”.

Désolé pour la mauvaise traduction mais mon problème seulement dans le forum français. :wink:

1 Like

Après des tests approfondis, je peux confirmer qu’avec la combinaison SafeSky-Stratux-SkyDemon, …Safesky plante sur mon iPhone et Ipad AIR2 de manière irrégulière. Cela se produit à la fois en air et au sol avec une connexion 4G stable. Seule la désactivation de Stratux dans la configuration de SafeSky rendra SafeSky à nouveau stable.

1 Like

Façon anormale de faire fonctionner Safesky + Stratux + Skydemon!

Lorsque vous utilisez Skydemon avec un Stratux, il est recommandé de régler l’IP du Stratux sur 192.168.1.1 (différent de l’IP standard 192.168.10.1). Lorsque que l’onglet sur aller voler dans Skydemon vous sélectionnez “FLARM avec Air Connect”. Ceci parce que sur cette IP un protocole différent (“plus similaire à FLARM”) est transmis.

En suivant ce raisonnement, j’ai sélectionné dans SS au lieu de Stratux, Power Flarm (et l’IP automatique au lieu de l’IP forcée 192.168.10.1 que j’utilisais auparavant) et étonnamment, dans cette configuration hors norme, les déconnexions de SS ne se sont plus produites (voir mon rapport précédent). Note : l’IP de Stratux est restée sur 192.168.10.1 et a été trouvée automatiquement!

Dans cette configuration un peu anormale, le trafic SS (marqué avec le préfixe ss) et le trafic Stratux apparaissent correctement dans Skydemon. Le GPS fonctionne également (à partir de Stratux ou de l’iPad, je ne sais pas).

Probablement cela aide à comprendre où se trouve le problème dans la configuration normale avec un Stratux.

1 Like

Bonsoir à tous,

Nous allons opérer des tests supplémentaires. Notez que Stratux même sans SafeSky présente sur Raspberry des soucis de stabilité. Vu que dans la configuration, c’est le stratux qui prend la main sur la localisation GPS, il est difficile de définir la source exacte du problème.
@Tristan qui a développé l’app ainsi que nos contacts chez Stratux allons voir plus en profondeur les soucis rencontrés.

Merci de les partager car c’est ainsi que nous pouvons avancer efficacement.

Bons vols à tous

Voici un résumé plus clair de ce que j’ai trouvé pour Tristan.

A) Configuration standard :
Stratux : IP : 192.168.1.1 (recommandé par Skydemon)
Safesky : sélection des périphériques de trafic externe = Stratux
Découverte automatique des appareils “OFF” et IP fixée à 192.168.1.1 (si Stratux n’est pas trouvé)
Skydemon : Appuyez sur “Go Flying” et sélectionnez “Use GDL90 Comp. Device”.

Résultat : après environ 30-50 sec. Safeaky cesse de fournir du trafic et Skydemon ne montre que le trafic de Stratux. Après quelques minutes, Safesky se plante et Skydemon perd sa position.

B) Configuration non standard :
Stratux : IP : 192.168.1.1 (comme avant)
Safesky : sélection du dispositif de trafic externe = PowerFLARM
Découverte automatique du dispositif “ON” (Safesky trouve automatiquement le Startux mais affiche PowerFLARM sur le bouton vert).
Skydemon : Appuyez sur “Go Flying” et sélectionnez “Use GDL90 Comp. Device”.

Résultat : le trafic de Stratux et de Safesky est affiché dans Skydemon et il n’y a plus de plantage.

Cela signifie que si vous faites croire à Safesky que votre Stratux est un PowerFLARM, cela fonctionne. Et vous n’avez même pas besoin de mettre l’adresse IP !

Bonne chance pour votre recherche :wink:

Hello
Merci pour ton retour, cela fait plaisir d’avoir de l’aide.
Aujourd’hui Tristan est sur la route du retour mais des demain il regardera le pourquoi de ce comportement étrange.
Nous sommes bien entendu en possession de stratux et powerflarm pour valider tout cela.

Cordialement.

Dernière contribution pour le moment :
J’ai vérifié la même chose avec les autres options pour les appareils externes dans SafeSky :
La procédure pour le Stratux (telle que décrite ci-dessus) fonctionne avec :
PowerFLARM, Levil, PilotAware (semble être le plus rapide) et SkyEcho.
Elle ne fonctionne pas avec Stratux (drôle) et Generic GDL90.
Pas besoin de se presser et meilleures salutations !
:slightly_smiling_face: :small_airplane:

Bonjour Wolfgang Xtof et Tristan,

Chez moi, le problème est le même quelle que soit l’adresse IP du Stratux et quel que soit le dispositif externe sélectionné dans SS. Étonnamment, je n’avais pas rencontré ce problème en utilisant SS avec mon Stratux sur Ipad lors de mes vols en novembre. Sur Android, tout fonctionne parfaitement bien. Je suspecte que le problème a commencé depuis la dernière mise à jour de SS ou bien depuis celle d’IpadOS (gestion des paquets WIFI + cellulaire ?). Je ne pense pas que Skydemon soit en cause car le bug survient même si Skydemon n’est pas lancé.

Bon vols

Bonjour, j’ai trouvé une “combine” permettant de recevoir les trafics de SS et du Stratux sur Skydemon pour Ipad. J’ai configuré le Stratux pour relayer le point d’accès (hotspot) de mon téléphone portable. Sur Ipad, je me connecte au WIFI du Stratux et je peux donc me connecter à internet. Je lance ensuite SS qui reçoit les données du Stratux mais aussi internet via le WIFI du Stratux. Je lance Skydemon en GDL90 et les trafics SS et ea apparaissent. Je crains toutefois une perte de connexion en vol. A tester quand la meteo le permettra…

Bonjour Tristan,

J’ai enfin trouvé la solution à mon problème. Une fois connecté au WIFI du Stratux, dans les “réglages WIFI” de l’Ipad, j’ai configuré la connexion au WIFI du Stratux en choisissant “configurer IPv4” puis “manuel”. J’ai ainsi attribué une adresse IP statique au Stratux (l’adresse 192.168.10.25 choisie automatiquement par l’Ipad). Dans les paramètres de “partage du trafic” de Safesky, j’ai ensuite modifié la connexion à Skydemon en désélectionnant la “découverte automatique du logiciel” et en renseignant l’adresse IP statique attribuée au Stratux (192.168.10.25). Petit test en vol ce matin : trafics de Safesky et du Stratux affichés sur Skydemon pendant toute la durée du vol (environ une heure).

Youpi !

Antoine

Merci, Antoine, j’aime me réveiller avec une solution pour laquelle je n’y suis pour rien :slight_smile:

Je n’ai pas encore regardé au souci, mais ton astuce donne une direction. Je reviens vers toi avec une solution permanente rapidement…

Fly Safe,

Tristan