No internet connection when connected to Stratux on Android

Hi all,

Lately, when I connect my Samsung Galaxy S22 to my Stratux via Wifi, I don’t see any traffic on SafeSky, as the phone tries to access the internet through the Stratux Wifi (which is obviously not connected to the internet). I haven’t found out how to configure my phone so that it still uses mobile data to access the internet. I didn’t have this problem before, not sure if it came with an Android update.
Does anyone else have this problem, too, or an idea for a solution?


I asked @Tristan to give your the solution.
It’s only concerned the android users. You need to configure android to access to the internet mobile if the wifi is not connected to the internet.
Just a config in your operating system.

I have done that, but unfortunately, it hasn’t solved the problem

Likewise. Haven’t flown for a month and now find the same issue. Sometimes the screen shows the "Big Red " error signal for “no internet”, yesterday had no traffic displayed, the day before, no map or traffic although SkyEcho was reporting. I’m putting together a short video to cover my SS experience so far, and Tristan is supporting that as well as addressing all these sorts of problems, so it will get fixed or explained eventually.

Good morning,

Have you tried with what is explained here:

I think this is well known problem. Stratux has a Wifi set as Access-Point only for its internal use.



If you’re refering to setting my Stratux to “Wi-Fi Direct”: I have tried this (also the “Access Point” setting), but unfortunately, it hasn’t solved the problem, either.


It’s important to note that this setup is independent of the SafeSky App itself and is instead a configuration specific with your phone’s operating system / version / vendor overlay.

We have below collected some common ways to solve this connectivity issue:

If you have any additional hints, please share them here so that we can improve the documentation.

Fly Safe,