Android 9/SkyEcho/SafeSky snag

Has anyone found a fix for Android 9 and previous versions not accepting mobile data when wifi is available even though that wifi does not have internet access as with SkyEcho 2 ?
As the only means of connecting SE2 to an EFB device is via it’s wifi SafeSky is effectively disconnected even though mobile data is on.
If you want both inputs to display on one device there needs to be a fix or a work round.
Any guidance appreciated.

1 Like

Hi Ark,
Although I am not yet a SS user I have no difficulty accessing cellphone network data when my SE2 is connected to my EFB (SkyDemon).
This is proved by SD displaying wind speed and direction (Navigation/Instrument options) and up to date METAR and TAF reports.
I run SD on a Samsung S8 Galaxy smartphone.
The only thing that I have observed is that SD appears to need a good cellphone network signal before selecting “Go Flying” mode.
Recent cellphone network issues at my local airfield meant that no cellphone data was available. I rarely get SD to “re-connect” to cellphone data when airborne unless a good signal was available before take-off.
Try experimenting with SS, SE2 and your EFB in a non aircraft environment, such as your car. That way you should be able to eliminate any possible aircraft related issues.

Hello tnowak
Thanks for your observations. My tests were static in my garden for the reason you mention with a reasonable mobile signal. With a SafeSky target visible it would disappear as soon as I allowed a connection to SE2 via it’s wifi. Turning off the wifi and the target reappeared. This was repeated numerous times with the same result.
SafeSky themselves I understand are aware of the issue but have not yet been able to suggest a remedy. I am told it is only an issue with Android 9 and earlier versions rather than 10 or later or Apple OS. From your experience it is not a universal problem if your Samsung runs 9?
I have difficulty logging on to SafeSky where there is no wifi and the mobile signal is poor which sounds similar to your SD ‘go flying’ difficulty. Sorry that is no help to you!

Try Speedify.

Thanks randole,
I did look at Speedify but thought a VPN type solution was adding a layer of complexity best avoided on the ‘keep it simple’ basis. I was hoping some easy tweak to Android would do the trick but nothing that simple has turned up. I am still hoping the clever SafeSky people will come up with a fix when they have less on their plate!

1 Like

Hello,
I have sa same problem, using Android 12.
When connected to SE2 via Wifi, SS does not use 4g for Internet-Access, but claims no Internet-Access.
When disabling WiFi, connection of SS to it’s Servers is working.
SS, please fix.
Thanks,
Johann

It worked fine on my Oneplus 8 Pro (Android) before… Suddenly after an Android upgrade i lost this functionality…

I think the problem is with Android software:(

The workaround, is what @randole mentioned, but this adds a layer of complexity.

Hi Jonas,
Sorry to hear you have lost that quite important function. ‘Upgrading’ from Android 11 to 12 seems to have deprived many users of the ability to stay connected via mobile data while using the ‘no internet access’ SE2 wifi. I suspect the developers are all using O/S so this serious failing is not being addressed.
As far as I can gather Android 7&8 should be OK, 9 is not but 10 and 11 are possibly OK but not 12. I can really only speak directly for my version of 9 so those that know please correct me.
Has anyone actually tried Speedify in the context of this question? I have not as the added load on my marginal tab and my pocket via a sub make it unattractive.
In your case I would consider just reverting to A11. For me I think it is a case of running SafeSky on a separate phone as it was originally intended unless the developers can help us out. In fairness it is really an Android problem but I rather fear there are SafeSky/Android/SE2 users who have this problem but may not realise it as it is not always blindingly obvious.

I don’t want to revert back to Android 10 or 11 just because of this, neither use a second phone…

Seems that the only way is to use Speedify on Android.

Understood Jonas, no one likes a too much stuff in the cockpit. Perhaps you can post on how that goes as I am sure there are plenty of others in the same situation who would like to know.
SafeSky could do more to say what works with what and what doesn’t even though it is not their fault. Tristan was looking at it but he didn’t get back to me so I guess there is no easy fix.
I look forward to reading your post once you have tried Speedify out.

2 Likes