“Enable external traffic device” switches itself off

After a lot of connectivity angst, I now understand the problem.

The “Enable external traffic device” switch switches itself off between uses.

If I check that it’s on just before I connect everything up, it all works. If I don’t, it doesn’t.

Does anyone know what makes it switch off?

Well, no-one else seems to answer questions on here, so I may as well talk to myself, in case it’s helpful to anyone :roll_eyes:

It seems that if you switch on SafeSky at any time when the WiFi is not connected to the traffic device, then the “Enable external traffic device” switch gets turned off until it is next manually turned on.

So, for example, if your phone connects to a nearby WiFi, or if you just want to look at traffic on the Internet, or if you switch things on in the wrong sequence, the SafeSky functionality turns off without alerting you.

Hi @Timothy,

Thank you for your detailed feedback and for sharing your experience with SafeSky and SkyEcho2 integration.

First, I want to clarify that the behavior you are experiencing is not a bug but an intentional feature. SafeSky automatically disables the “Use external traffic device” option when it cannot communicate with SkyEcho2. This design is in place to ensure that, if you are flying without SkyEcho, the application can still function correctly.

We will evaluate what we can do to improve this, especially for users who sometimes fly with SkyEcho and sometimes without.

In the meantime, please ensure you connect to the SkyEcho2 WiFi before starting SafeSky to avoid these issues. If SkyEcho2 is not available, it must be disabled for SafeSky to work correctly with other applications like SkyDemon.

Thank you again for your feedback.

Thank you for your response.

I think that you are slightly missing the point. I always fly with SkyEcho2 running, but there are circumstances when SafeSky is running, but unable to see it. For example if used on the ground to look at traffic, or if the iPhone changes Wi-Fi to a nearby hotspot, as sometimes happens.

My suggestion in my email to you, which prompted this response, was that you should change the functionality of the switch to “Enable external traffic device when available”. That would mean that a momentary break in service would not permanently disable the external device, which would be much more user-friendly.

That happened to me yesterday when I was going to fly. I connected SkyEcho via wifi and then started SafeSky and I noticed that the " connect external device " button was off. I now know I have always have to check this button for each flight when using SkyEcho ( always do)