Call sign is not visible

When I take off, I see my plane icon including altitude, but call sign is not visible.
This problem is for desktop map and for app map in mobile phone too.
For others planes I see it correctly.

I tryied to change my call sign (with dash character, without it…) and problem is continuing.

I am using free version of SafeSky.

SafeSky assumes you wish to remain anonymous. For callsign to show you need to go into settings bottom right. Then on next page click top right above your profile name. This now enters your profile info. Scroll down until you see Public Profile and switch this on. Now click save top right. I would then log out and log back in. You should now, and everyone else, see your call sign instead of just your aircraft symbol. Cheers

Thanks for help, my set up was correct (Traffic sharing switch ON), I log out and log in twice and after that all is OK… :slight_smile:

Good to see that it’s working fine now.
Thanks @Ridgeskimmer for this answer :wink: