Aircraft registration


I was using SafeSky and SkyDemon today, on 2 different devices, connected via hotspot and noticed that SkyDemon running on a Lenovo tablet showed registrations of other aircraft incorrectly. There was always a prefix “sy”. I mean instead of OMTWO it showed syOMTWO. Please see attached screenshots. It was the same for all traffic that I could see. However, SafeSky running on a Xiaomi cell phone showed these registrations correctly.
Can you please let me know what should be done to fix that. I am a Premium user.



There is a setting on the “traffic sharing” screen.

‘Highlight Safesky traffic’ which if selected appends the sy to the beginning of safesky provided traffic.

I think this is selected by default.

I also disabled this option: the fact that SafeSky traffic is blue is enough to spot them.
Seing the logo of this option, I have the impression that it is a left over “debug” option ;-).

This option becomes relevant only when SafeSky is used with a SkyEcho or PowerFLARM device, as it allows users to differentiate between SafeSky traffic and traffic received from the external device. :slight_smile:

Based on your feedback, we are going to turn it off by default on our next release.

Fly Safe everyone,


I disabled it and it’s all good now :slight_smile:

Thanks for your quick responses,