Safesky empty white map with flashing red dot

Seeing empty map display with a flashing red dot in top left on multiple android devices.

problem resolved after clearing cache or uninstall/reinstall but then fails again within a day.

anyone any ideas? at the moment this app doesn’t appear to work properly on android.


I am not an engineer or a geek. So I don’t know why it doesn’t works on your device
I am just an user of SafeSky.

But I can say that this App works perfectely on many different Androïd devices. That’s the feedback I received from many pilots in France and Belgium.
I have a Xiaomi M10 Lite, a Samsung A52 , a Huawei Mediapad M5, a Xiaomi Mi Max and SafeSky runs perfectely on all those devices.

I still have flown 2 days ago between Basiy-Thy in Belgium and Beaunes in France at 6.500Ft with an Internet connexion about 90% of my 2x 2 hours flight. SafeSky showed me several trafics (aircrafts and gliders). I also encountered two traffics not reported by Safesky, one of which was unknown to the TMA controller.

It’s a pity to do without SafeSky which gives more than 90% of the trafics (that broadcast something) during more than 90% of the flight time up to 4500Ft. Before I had nothing to see the trafic in flight. Why go without something so great and free?

I wish nice flights.

I agree, it’s a great app (and I am a software engineer and wish I had have thought of it myself!)

but want to try to get help to identify why its not working on Samsung androids ( at least 3 different models that I’ve tried it on).

there doesn’t seem to be a support email that I can contact

Hi, indeed, we do not have support - it’s a free app…
But if you want, send me a private message with the devices you tried. I have tested it on a lot of samsung tablets and cellphones. Android 7 is the minimum.